Zentralschalter Fensterheber - Fehler im Schaltplan!!!
#1
Hallo,

ich habe herausgefunden, dass in allen Schaltplänen und in SSP156 ein Fehler hinsichtlich der inneren Verdrahtung des Zentralschalters Fensterheber in der Mittelkonsole vorhanden ist. 

Dort ist eine Verbindung eingezeichnet, die so nicht existiert!!!!

Aber Bilder sagen mehr als Worte, so dass ich auf meine nachstehende Grafik verweise.

   

   

Ich hoffe, das hilft ....

Lieber Gruss

Ingo
Zitieren
Bedankt durch:
#2
Hallo Ingo,

ich habe zwar auch schon einige Fehler in den SLP gefunden, denke aber, hier irrst Du.

Der Schalter ist der "stinknormale" FH-Schalter, der nur deshalb eine andere Teilenummer hat, weil er in einem anderen Gehäuse steckt.

Der Test an meinem Zentralschalter war erfolgreich. In Ruhelage Durchgang von 1 nach 3, wechselt von 1 nach 4, wenn man schaltet. Andere Seite (Durchgang von 2 nach 5, wechselt von 2 nach 4) ebenfalls ohne Befund.

Check mal die Durchgänge an einem anderen Schalter. Vermutlich ist Dein Zentralschalter defekt.

Gruß
Peter
Was stört es die deutsche Eiche, wenn sich eine Wildsau an ihr reibt?  Ich lach mich wech
Mein PN-Speicher ist voll. Bei Fragen oder Hinweisen bitte eine Email schreiben.
Zitieren
Bedankt durch: Ingo K.
#3
Wir reden von diesem Schalter, nicht wahr?

   

Dann würde ja in Neutralstellung des Schalters an Input B8 des Verdecksteuergeärts +12V (HIGH) anliegen und bei Betätigung des Schalters 0V (LOW=Masse), ist das denn so richtig??

Ich messe aber heute abend nochmal nach ...

Ingo

Das hat mir jetzt keine Ruhe gelassen und ich habe extra die kleine Platine abgelötet; keine Verbindung von 1 nach 3 in Ruhelage vorhanden!!!! 3 hängt völlig frei in der Luft und hat keinerlei Verbindung nach irgendwohin.

Hier ist auch nichts verbaut oder verbastelt worden; bin Erstbesitzer seit 1995.

Hab mal ein paar Fotos vom Innenleben gemacht:

                                   

Hier noch mal Detailaufnahme, KEINE Verbindung PIN3 mit PIN1 im Ruhezustand vorgesehen:

   

Wäre schön, wenn mich jemand aufklären könnte.

- Ingo

Mein Schalter hat die Nummer LU 8GO 959 851 A!!!

Bei ebay habe ich Schalter gesehen ohne die Suffix "A". Gibt es da möglicherweise mehrere (unteschiedliche) Versionen??
Zitieren
Bedankt durch:
#4
Hallo Ingo,

vielen Dank für Deine Bemühungen und die Bilder.
Ich habe selbstverständlich auch den Zentralschalter (aus meinem Spender) getestet. Zerlegen möchte ich den aber nicht um das Innenleben zu vergleichen. Meinen anderen Schalter kann ich leider nicht finden, um das noch einmal gegenzuchecken.
Ich wollte aber einen anderen Schalter opfern, da ich der Meinung war, die sind alle baugleich. Dafür wollte ich einen Schalter nehmen, von dem ich der Meinung war, die Beleuchtung ist defekt. Die Schalter gibt es im Zubehör für ein paar Euros neu und da lohnt sich für mich eine Reparatur nicht. Dabei habe ich dann festgestellt, dass alle i.O. sind, man darf nur + und - nicht vertauschen.
Au Backe 
Und bei allen Schaltern muss + an 4 und - an 3. Nur bei meinem Zentralschalter ist es umgekehrt. Huh
Da bin ich mir aber nicht sicher, ob da nicht der Vorbesitzer "rumgefummelt" hat. Es gibt hier einen Beitrag, wo er, so glaube ich mich zu erinnern, die Schalterbeleuchtungen erneuert hat.
Nein, Dein Bild aus dem SSP bestätigt, dass das so richtig ist (31 = Masse an 4 und 15a = Plus an 3). Die Schalter unterscheiden sich tatsächlich und der von mir getestete Schalter ist auch der Richtige.

Ich habe aber einen ganz anderen Verdacht. So wie ich das auf den Bildern zu erkennen glaube, fehlt da eine Lötstelle (s. Markierung)?

[Bild: zentralschalterz8jn7.jpg]

Und das sieht für mich nicht so aus, als ob die planmäßig fehlt. Vergleicht man das mit der anderen Seite, wo die Verbindung von 2 nach 5 in Ruhelage da ist, müsste m.M.n. auch die Verbindung von 1 nach 3 in Ruhelage da sein, wenn die Lötstelle i.O. ist.

Richtig ist aber die Teilenummer 8G0959851 - NULL, nicht Oooooh. Den Schalter gibt es bei Audi TR noch neu.
Ohne Index A ist die Vorgängernummer, die durch die aktuelle Nummer ersetzt wurde. Die müssen also baugleich sein. Ich habe aus dem Spender (aus 1991) auch den Schalter ohne Index.


Darf man fragen, warum Du den Schalter zerlegt hast? Hast Du jetzt einen anderen Schalter eingebaut? Funktioniert damit alles? Ist da die Verbindung da?

Klarheit werden wir wohl erst bekommen, wenn ich meinen anderen Schalter wiederfinde oder Jemand ein Neuteil bei TR bestellt.

Schönen Abend
Peter


Nachtrag:

Noch ein Hinweis zu Deinem letzten Bild:
Die Pins 1 und 2 gehen nicht zum FH-Steuergerät sondern zum Verdecksteuergerät - zumindest beim NG aus 1992. Ich bin mir aber ziemlich sicher - ohne nachzusehen - dass das bei den anderen Modellen genauso ist.
Was stört es die deutsche Eiche, wenn sich eine Wildsau an ihr reibt?  Ich lach mich wech
Mein PN-Speicher ist voll. Bei Fragen oder Hinweisen bitte eine Email schreiben.
Zitieren
Bedankt durch: Ingo K.
#5
@Peter_Pan:

Danke, dass Du Dich so intensiv damit beschäftigt hast - sehr interessante Kommunikation hier mit Dir.

Ich denke nicht, dass das ein Fehler im Platinenlayout ist, das sieht mir von der Rundung her bewusst so aus.

Imho ist es für den Zentral-Fensterheberschalter völlig egal, ob 5 und 3 Verbindung zu +12VDC haben. Das ist nämlich gar nicht erforderlich, da die beiden Eingänge B7 und B8 im Steuergerät durch pullups auf definiertes Potential, nämlich +12VDC gezogen werden, damit diese nicht floaten und einfach in der Luft hängen.

Wird nun der Schalter geschlossen, kommt Potential LOW auf den input B7 oder B8, dann folgt eine Verarbeitung dieses LOW Signals durch ein paar Transistoren+TTL+CPU, raus kommt dann ein HIGH Siignal an das gate des Mosfets (BUZ11), der Mosfet schaltet durch und "zieht gegen Masse", so dass dann Masse am Steuergerät Ausgang A1 oder A8 anliegt, wodurch dann eines der Relais J291 oder J292 angezogen wird. (Die 5 Sekunden Einschaltdauer bei Verdeckentriegelung wird übrignes im Verdecksteuergerät erzeugt, nicht im Fensterhebersteuergerät).

Schau mal auf meine angehängte Grafik (noch ein work in progress), Bilder sagen mehr als Worte.

Hintergrund, warum ich mich damit so intensiv beschägtige ist folgender:
Mein Verdeck funktioniert perfekt, nur das Herunterfahren der Fenster beim Betätigen der Verdeckentriegelung funktioniert nicht.

Da ich das Verdecksteuergerät 8G0 959 255 OHNE Suffix "A" habe, habe ich mir für sage und schreibe 579 Euro ein neues Steuergerät gekauft, womit alles funktioniert. Also liegt der Fehler definitiv im Verdecksteuergerät.

Dann habe ich mein Verdecksteuergerät geöffnet und mal ein wenig durchgemessen. Wie häufig war einer der Schalttransistoren (hier der Mosfet BUZ11) defekt, getauscht, alles funktioniert wieder. Da sag mal einer, dass man am Steuergerät selbst nichts reparieren kann.

Dann habe ich bei ebay noch ein weiteres als defekt augewiesenes Steuergerät für 10 Euro gekauft, bei dem angeblich auch die Fensterabsenkung nicht funktionierte. Hier habe ich dann auch die beiden Mosfets durchgemessen, diese waren aber in Ordnung. Bei diesem Steuergerät wird dann das EINGANGS-Signal an B7 oder B8 nicht ordnungsgemäß verarbeitet und es kommt am Ausgang A1 oder A8 kein LOW Signal an.
Hier liegt der Fehler also zwischen INPUT und OUTPUT. Ich vermute, dass einer der pullups an B7 oder B8 (ausgebildet als Widerstandsnetzwerk) defekt ist oder etwas in den Transistoren dahinter.

Auf dem Steuergerät befindet sich ein Microcontroller/CPU, vermutlich ein programmierter Baustein, den man nie wieder beschaffen kann, dieser dürfte aber nicht defekt sein, da ich das Steuergerät ja auslasen kann.

Wenn man sich im übrigen die Platine mal anschaut, dann ist das primitive Elektronik aus 1990, wenn man bloß einen Schaltplan hätte, wäre das ein Einfaches, da ein paar diskrete Bauteile zu tauschen (wobei ich vermute, dass in 90 % aller Fälle einer der Mosfets die Grätsche gemacht hat).

Leider sind die Bauteile alle aus den 90er Jahren und teilweise findet man bei der Suche nach den Bauteilbezeichnungen nichts.

Vielleicht können wir uns, wenn ich heute Abend mal Detailaufnahmen von einigen Bauteilen machen, mal gemeinsam an die Identifizierung der Bauteile machen, damit in Zukunft nicht mehr Steuergeräte weggeschmissen werden, auf denen ein Mosfettausch für 50 Cent den Fehler beseitigen würde.

Im Winter werde ich mich dann wohl mal da dran begeben, das Steuergerät mit einem PIC nachzubauen, es kann mit der heutigen Technik nicht so schwer sein, (nur) 22 Einganssignale so zu verarbeiten, dass 13 Ausgäge angesteuert werden.

- Ingo

   

Ein zusätzlicher 1K Widerstand parallel zu dem vorhandenen 3K9 Widerstand beleuchtet den Zentral-Fensterheberschalter viel besser - ganz einfache Modifizierung 

Auch hier sagen Bilder mehr als Worte.

   

Habe im übrigen, wo ich gerade den vorderen Dachrahmen mal ab hatte, ein kleines Video gemacht, wo man die Funktion von F172+F205+dem Dachrahmenmagnet sehen kann.

https://www.youtube.com/watch?v=xA7eabBVX8M

Hab für die "Nachwelt" auch mal (etwas laienhaft) meinen Schalter dokumentiert, sollte selbsterklärend sein. Die Pad-Bezeichnungen etc. sind von mir.

   
Zitieren
Bedankt durch:
#6
(23.07.2019, 12:50)Ingo K. schrieb: ... dass Du Dich so intensiv damit beschäftigt hast - sehr interessante Kommunikation hier mit Dir. ...

Hallo Ingo,

vielen Dank für die "Blumen". Entweder interessiere ich mich für etwas und versuche es vollständig und nachvollziehbar zu (er-)klären oder ich halte einfach mal ... mich raus.
Zwinker
Es gibt aber auch (hier) "Zeitgenossen", die das völlig anders sehen und Menschen wie Dir und mir wegen ihrer Gründlichkeit und ihrer eigenen Oberflächlichkeit Dinge wie "egal" unterstellen.
So what!
Ich lach mich wech

Vom Zentralschalter zum Verdecksteuergerät ist ja schon ein gewaltiger Sprung. Zum Schalter kann ich nichts Neues berichten, da mein zweiter Schalter immer noch nicht auffindbar ist. Ich kann also nur den Ist-Zustand beschreiben.

Deinem Beitrag kann ich noch bei den Angliszismen INPUT und OUTPUT folgen. Danach hört es dann aber auf. Eine simple Klick-Klack-Relaisschaltung krieg ich locker noch hin, aber die Steuergeräte selbst mit ihrem Innenleben sind für mich "Black Boxes".
Solange ich weiß, was wo reingehen muss, um dann woanders wie rauszukommen. ist alles gut. Im Innenleben erkenne ich allenfalls noch einen Widerstand - vielleicht noch einen Kondensator oder IC - aber dann ist "Ende Gelände".
Man(n) kann und muss nicht alles wissen.

Wie ich sehe, hast Du ja auch schon im Thema von Meschi gelesen, wo es darum geht, ggfs. die Verdecksteuergeräte nachzubauen. Mein bescheidener Beitrag dazu ist gesetzt.
Du hast ja schon einiges an Vorarbeit geleistet.  Erste Sahne
Ich habe mich bisher erst mal auf das FH-Steuergerät konzentriert und mit einer Funktionsmatrix begonnen. Mir fehlten aber bisher Informationen zu Eingangssignalen, die ich aber mittlerweile habe. Das Thema hat aber für mich im Moment keine 1-Priorität.
Wir sollten uns dazu mal ausserhalb des Forums austauschen und schauen, was machbar ist.

Eine meiner Lieblings-Leitsprüche ist:
Alle sagten: Das geht nicht. Bis einer kam, der das nicht wusste und einfach machte.
Zwinker

Gruß
Peter
Was stört es die deutsche Eiche, wenn sich eine Wildsau an ihr reibt?  Ich lach mich wech
Mein PN-Speicher ist voll. Bei Fragen oder Hinweisen bitte eine Email schreiben.
Zitieren
Bedankt durch:


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Airbag Fehler 00588 JoeCotty 5 867 01.08.2022, 13:11
Letzter Beitrag: Lord of the Rings
  [Elektrisch] Suche Schaltplan Wischer MainzMichel 0 475 16.01.2022, 15:52
Letzter Beitrag: MainzMichel
  Klimaanlage elektrischer Fehler Burns 9 3.387 24.08.2020, 22:20
Letzter Beitrag: hightower
  Zentralverriegelung mgl. Fehler!? Baeda 2 922 13.09.2019, 16:44
Letzter Beitrag: Saar-Robert
  [ABC] Audio Schaltplan percy 2 839 11.05.2019, 13:23
Letzter Beitrag: percy
  schaltplan doppel Airbag JensEngelbert 2 6.529 20.03.2019, 01:27
Letzter Beitrag: Audi Cabrio Fan
  [1Z/AHU] Schaltplan gesucht Meschi 4 1.335 17.07.2018, 13:59
Letzter Beitrag: Peter_Pan
  [Problem] EFH-Zentralschalter fährt Scheiben nicht runter raba 36 9.228 20.05.2018, 23:17
Letzter Beitrag: kb90imsa
  Fehler 01367 - Abschaltung Pumpe ZV / Symptome, Ursache + Lösung bngbR 7 6.429 06.05.2018, 20:30
Letzter Beitrag: Tux
  Schaltplan ECU und WFS JoeCotty 6 2.239 28.02.2018, 20:39
Letzter Beitrag: Peter_Pan



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste